Back to overview
Maintenance

Site Maintenance

May 17, 2026 at 9:30am UTC  –  May 17, 2026 at 3:30pm UTC
Affected services
mediux.pro
api.mediux.pro

Resolved
May 17, 2026 at 3:30pm UTC

Maintenance ended

Created
May 17, 2026 at 9:30am UTC

Site and API will be down for maintenance Sunday 17/05/26